const regex = /\d(?=\d{4})/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?=\\d{4})', 'mg')
const str = `123451234`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);