$re = '/\d(?=\d{4})/m';
$str = '123451234';
$subst = "#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;