$re = '/^.*\bword\b.*$(*SKIP)(*F)|(.+)/m';
$str = 'string has word
string does not have it
another string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);