re = /^.*\bword\b.*$(*SKIP)(*F)|(.+)/m
str = 'string has word
string does not have it
another string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end