const regex = /(?<!\d)(55)(?!\d)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)(55)(?!\\d)', 'mg')
const str = `155
559
1559
55
55z
a55
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}