$re = '/(?<!\d)(55)(?!\d)/m';
$str = '155
559
1559
55
55z
a55
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);