package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+)\s(.*?)\sat\s(.*$)`)
var str = `1 Book on wombats at 12.99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}