$re = '/^(\S+)\s(.*?)\sat\s(.*$)/m';
$str = '1 Book on wombats at 12.99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);