package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\([0-255],[0-255]\))*`)
var str = `(15,3)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}