$re = '/(\([0-255],[0-255]\))*/';
$str = '(15,3)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);