const regex = /(\d{4})\s+(.*?)\s+(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})\\s+(.*?)\\s+(.*)', '')
const str = `1158 Budapest Késmárk u. 7/b.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}