$re = '/(\d{4})\s+(.*?)\s+(.*)/';
$str = '1158 Budapest Késmárk u. 7/b.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);