package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[EHT]\d{6}`)
var str = `E123456
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}