$re = '/\b[EHT]\d{6}/';
$str = 'E123456
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);