$re = '/\w*(?:\[|,|^)[\t ]*((?\'type\'[a-zA-Z0-9_.\[\]]+)(?:[\t ]*\|[\t ]*(?&type))+)(?:\]|,|$)/m';
$str = 'str|int|bool
int | tuple[str|int] | bool
Decimal|datetime.date|str
str|Optional[int]
Optional[int|str]
dict[str | int, list[B | C | Optional[D]]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);