import re
regex = re.compile(r"\w*(?:\[|,|^)[\t ]*((?'type'[a-zA-Z0-9_.\[\]]+)(?:[\t ]*\|[\t ]*(?&type))+)(?:\]|,|$)", flags=re.MULTILINE)
test_str = ("str|int|bool\n"
"int | tuple[str|int] | bool\n"
"Decimal|datetime.date|str\n"
"str|Optional[int]\n"
"Optional[int|str]\n"
"dict[str | int, list[B | C | Optional[D]]]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")