const regex = new RegExp('((?:^|,\\s).*?)(?=,\\s\\S+;|$)', 'gm')
const str = `has_recent_activity=1; path=/; expires=Fri, 28 Dec 2018 09:07:30 -0000, logged_in=no; domain=.github.com; path=/; expires=Tue, 28 Dec 2038 08:07:30 -0000; secure; HttpOnly, _gh_sess=NG4xelVwV0JLV2ppUTVxQXArT2Y1TFRHdGlTanJ2QUwrV2t1MjVVZGF3eFk3Q2FsamJnVmNLdXZlanBRQzUrei9oSkl5WTY2ZkUzb04yQ1lReStNUHdVVWpwWXJUSmxGVmdleHIrU2ZNc3V0Y2FsZUpFb2Y1TnNTNExHYUg1a0x1dHhKZ3dLQ0lNWVEyenZEb2NoYnFaQ0l6VlBjNElQVkNNRHBBZlFmRDBlQmhXb0Q1Z0dKc2lUYlIvVHF4bVJwampPbjZnSDZ5MUV4YVozMmx5eDF3dz09LS1nNjZ5QWVMWlNiSlhsUUNqR0k4U2l3PT0%3D--bd93a324c5ca26bb447180edaa0029498908afb8; path=/; secure; HttpOnly`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}