# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\+ \(\w+\)(composeView\(.*?\))/class func \1/g;t' <<< "- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)"