using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+ \(\w+\)(composeView\(.*?\))";
string substitution = @"class func \1";
string input = @"- (void)composeView(...) gives func composeView(...)
+ (void)composeView(...) gives class func composeView(...)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}