use strict;
my $str = '12345some textqwert
12345some text qwer
1234some textqwert
Force the first 5 digits to be only numbers and the last 5 digits to be only letters?';
my $regex = qr/^\d{5}.*[a-zA-Z]{5}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}