$re = '/^\d{5}.*[a-zA-Z]{5}$/m';
$str = '12345some textqwert
12345some text qwer
1234some textqwert
Force the first 5 digits to be only numbers and the last 5 digits to be only letters?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);