const regex = /[\\?&]([^&=]+)=([^&=]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\\?&]([^&=]+)=([^&=]+)', 'gi')
const str = `?at=FCoKtkupr0GgZCxuxr4zk8k4xaE5T2XIQzi8Dl9v84w=&palt=awesome`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}