import re
regex = re.compile(r"\b(\w+ \w+\b(?: \w+\.)?)", flags=re.MULTILINE | re.UNICODE)
test_str = ("GIVEN:\n"
"Paul Millsap Al Horford Tiago Splitter Jeff Teague Kyle Korver Thabo Sefolosha Mike Scott Shelvin Mack Kent Bazemore Dennis Schröder Tim Hardaway Jr. Walter Tavares Justin Holiday Mike Muscala Lamar Patterson Terran Petteway\n\n"
"DESIRED:\n"
"Paul Millsap, Al Horford, Tiago Splitter, Jeff Teague, Kyle Korver, Thabo Sefolosha, Mike Scott, Shelvin Mack, Kent Bazemore, Dennis Schröder, Tim Hardaway Jr., Walter Tavares, Justin Holiday, Mike Muscala, Lamar Patterson, Terran Petteway,")
subst = "\\1,"
result = regex.sub(subst, test_str)
if result:
print(result)