re = /\b(\w+ \w+\b(?: \w+\.)?)/m
str = 'GIVEN:
Paul Millsap Al Horford Tiago Splitter Jeff Teague Kyle Korver Thabo Sefolosha Mike Scott Shelvin Mack Kent Bazemore Dennis Schröder Tim Hardaway Jr. Walter Tavares Justin Holiday Mike Muscala Lamar Patterson Terran Petteway
DESIRED:
Paul Millsap, Al Horford, Tiago Splitter, Jeff Teague, Kyle Korver, Thabo Sefolosha, Mike Scott, Shelvin Mack, Kent Bazemore, Dennis Schröder, Tim Hardaway Jr., Walter Tavares, Justin Holiday, Mike Muscala, Lamar Patterson, Terran Petteway,'
subst = '\\1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result