re = /([\d:\h,]+ --> [\d:,]+)/
str = '1 00:00:30,304 --> 00:00:34,165 Our focus today is to share with you 2 00:00:34,165 --> 00:00:36,715 key components of preparing and submitting 3 00:00:36,715 --> 00:00:40,715 a warranty transaction...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result