package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-4][\d](\.[0-5]*)?)$`)
var str = `30.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}