#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)\s*<div class="new">.*?href="((?:.*?)channel=(.*?))".*?src="(.*?)".*?</a>\s*</div>"
Local $sString = "<div class="new"> <a class="block" target="_blank" href="http://somesite:8080/hls/mango1.m3u8?token=34523sedfsdfsdf&e=123456789&channel=mango1" data-toggle="modal" data-target="#mango1">" & @CRLF & _
"<div class="image-container"> <img src="images/mango1.png" class="img-responsive" > </div>" & @CRLF & _
"</a> </div>" & @CRLF & _
"" & @CRLF & _
" <div class="new"> <a class="block" target="_blank" href="http://somesite:8080/hls/mango2.m3u8?token=sfaesfraesgh452342&e=987654321&channel=mango2" data-toggle="modal" data-target="#mango2">" & @CRLF & _
"<div class="image-container"> <img src="images/mango2.png" class="img-responsive" > </div>" & @CRLF & _
"</a> </div>"
Local $sSubst = "HREF: \1\nCHANNEL: \2\nSRC: \3\n\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)