using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^crfl.,](?=(\.|\,|\s|\Z))";
string substitution = @"";
string input = @"car. cupid, fof bob lol. koc coc, cob ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}