import re
regex = re.compile(r"[^crfl.,](?=(\.|\,|\s|\Z))")
test_str = "car. cupid, fof bob lol. koc coc, cob "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)