#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<=\|).+?(?=\|\W)"
Local $sString = "{{Infobox အတ္ထုပ္ပတ္တိ" & @CRLF & _
" | အမည် =စိုးသူ " & @CRLF & _
" | ဓာတ်ပုံ =Soe Thu.jpg" & @CRLF & _
" | သက်တမ်း = " & @CRLF & _
" | မွေးသက္ကရာဇ် = [[နိုဝင်ဘာ]] ၃၀ ရက်" & @CRLF & _
" | အမည်ရင်း =စိုးသူလွင် " & @CRLF & _
" | မိဘအမည် =ဦးခင်မောင်လွင်+ဒေါ်ခင်သူဇာ" & @CRLF & _
" | မွေးဖွားရာဒေသ= " & @CRLF & _
" | နိုင်ငံသား =[[Image:Flag of Myanmar.png|25px]] မြန်မာ" & @CRLF & _
" | လူမျိုး =ဗမာ" & @CRLF & _
" | ကိုးကွယ်သည့်ဘာသာ =ဗုဒ္ဓဘာသာ" & @CRLF & _
" | ပညာအရည်အချင်း = M.B;B.S" & @CRLF & _
" | အလုပ်အကိုင် = ဆရာဝန် ရုပ်ရှင်သရုပ်ဆောင်၊ အဆိုတော်" & @CRLF & _
" | ကြင်ဖော် = ခင်မြမြဝတ်မှုန်ဆွေ" & @CRLF & _
" | သားသမီး =" & @CRLF & _
" | ထင်ပေါ်ကျော်ကြားမှု =အကယ်ဒမီရ မင်းသား" & @CRLF & _
" | ထင်ရှားသည့်လက်ရာများ=" & @CRLF & _
" | ရရှိခဲ့သည့်ဘွဲ့တံဆိပ်များ=မြန်မာ့ ရုပ်ရှင် ထူးချွန်ဆု" & @CRLF & _
" | ကွယ်လွန်ရက် =" & @CRLF & _
" | ကွယ်လွန်ရာဒေသ=" & @CRLF & _
" | လက်မှတ်=" & @CRLF & _
" | ကွန်ယက် =http://www.facebook.com/pages/Soe-Thu" & @CRLF & _
" }}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")