use strict;
my $str = '{{Infobox အတ္ထုပ္ပတ္တိ
| အမည် =စိုးသူ
| ဓာတ်ပုံ =Soe Thu.jpg
| သက်တမ်း =
| မွေးသက္ကရာဇ် = [[နိုဝင်ဘာ]] ၃၀ ရက်
| အမည်ရင်း =စိုးသူလွင်
| မိဘအမည် =ဦးခင်မောင်လွင်+ဒေါ်ခင်သူဇာ
| မွေးဖွားရာဒေသ=
| နိုင်ငံသား =[[Image:Flag of Myanmar.png|25px]] မြန်မာ
| လူမျိုး =ဗမာ
| ကိုးကွယ်သည့်ဘာသာ =ဗုဒ္ဓဘာသာ
| ပညာအရည်အချင်း = M.B;B.S
| အလုပ်အကိုင် = ဆရာဝန် ရုပ်ရှင်သရုပ်ဆောင်၊ အဆိုတော်
| ကြင်ဖော် = ခင်မြမြဝတ်မှုန်ဆွေ
| သားသမီး =
| ထင်ပေါ်ကျော်ကြားမှု =အကယ်ဒမီရ မင်းသား
| ထင်ရှားသည့်လက်ရာများ=
| ရရှိခဲ့သည့်ဘွဲ့တံဆိပ်များ=မြန်မာ့ ရုပ်ရှင် ထူးချွန်ဆု
| ကွယ်လွန်ရက် =
| ကွယ်လွန်ရာဒေသ=
| လက်မှတ်=
| ကွန်ယက် =http://www.facebook.com/pages/Soe-Thu
}}';
my $regex = qr/(?<=\|).+?(?=\|\W)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}