#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^[0031]{4}[0-9]{8}[^a-z]|^[\+][0-9]{10}[^a-z]|^[06]{2}[\-][0-9]{7}[^a-z]|^[0-9]{3}[\-][0-9]{6}[^a-z]|^[0]{1}[0-9]{8}[^a-z]"
Local $sString = "0031612239646"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")