$re = '/^[0031]{4}[0-9]{8}[^a-z]|^[\+][0-9]{10}[^a-z]|^[06]{2}[\-][0-9]{7}[^a-z]|^[0-9]{3}[\-][0-9]{6}[^a-z]|^[0]{1}[0-9]{8}[^a-z]/i';
$str = '0031612239646';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);