$re = '/^(?!white$|.*(?:cat.*dog|dog.*cat)).*$/im';
$str = 'A dog with a cat.
Cat with a dog.
White
whiter
whit
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);