re = /^(?!white$|.*(?:cat.*dog|dog.*cat)).*$/im
str = 'A dog with a cat.
Cat with a dog.
White
whiter
whit
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end