import re
regex = re.compile(r"<(\w+)\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['\"][^'\"]*['\"]\s*)?)(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['\"][^'\"]*['\"]\s*)?)(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['\"][^'\"]*['\"]\s*)?)[^>]*>")
test_str = ("<p data=\"_data\" name=\"someName\" style=\"border: 1px solid black\" id=\"scott\" foo=\"bar\" foo=\"bar\" class=\"someClass\" foo=\"bar\">kjasdkfja;lsdkf</p>\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")