re = /<(\w+)\s*(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['"][^'"]*['"]\s*)?)(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['"][^'"]*['"]\s*)?)(?:(?:(?:(?!class=|id=|name=)[^>]))*((?:class|id|name)=['"][^'"]*['"]\s*)?)[^>]*>/
str = '<p data="_data" name="someName" style="border: 1px solid black" id="scott" foo="bar" foo="bar" class="someClass" foo="bar">kjasdkfja;lsdkf</p>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end