package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)[^\d]+([+-]?[0-9]{1,3}(?:,?[0-9]{3})*(?:\.[0-9]{2})?)$`)
var str = `2 book at 12.99
4 potato chips at 3.99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}