import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^r\\s(?P<nickname>\\b\\S+\\b).*\\n\n"
+ "^s\\b.*?(?P<type>\\bGuard\\b).*\\n\n"
+ "^v.*\\n\n"
+ "^w\\s.*?(?P<bandwidth>\\b[0-9]+\\b)";
final String string = "r Tor4ever AAcif1htILdru0BO0qX7OwGVhAU oHlbWBdaN3+QSleqBVL9/yAdcRs 2014-07-31 21:42:43 \n"
+ "s Exit Fast Guard HSDir Running V2Dir Valid \n"
+ "v Tor 0.2.4.21 \n"
+ "w Bandwidth=231 \n"
+ "p reject 25,119,135-139,445,563,1214,4661-4666,6346-6429,6699,6881-6999 \n"
+ "r Tornin AA8YrCza5McQugiY3J4h5y4BF9g vNRd1kyQ0i9UsVwYq5YFPHJi3jw 2014-08-01 00:26:18 \n"
+ "s Fast Guard HSDir Named Running Stable V2Dir Valid \n"
+ "v Tor 0.2.4.23 \n"
+ "w Bandwidth=713 \n"
+ "p reject 1-65535";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}