# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^r\s(?P<nickname>\b\S+\b).*\n
^s\b.*?(?P<type>\bGuard\b).*\n
^v.*\n
^w\s.*?(?P<bandwidth>\b[0-9]+\b)
"""
test_str = ("r Tor4ever AAcif1htILdru0BO0qX7OwGVhAU oHlbWBdaN3+QSleqBVL9/yAdcRs 2014-07-31 21:42:43 \n"
"s Exit Fast Guard HSDir Running V2Dir Valid \n"
"v Tor 0.2.4.21 \n"
"w Bandwidth=231 \n"
"p reject 25,119,135-139,445,563,1214,4661-4666,6346-6429,6699,6881-6999 \n"
"r Tornin AA8YrCza5McQugiY3J4h5y4BF9g vNRd1kyQ0i9UsVwYq5YFPHJi3jw 2014-08-01 00:26:18 \n"
"s Fast Guard HSDir Named Running Stable V2Dir Valid \n"
"v Tor 0.2.4.23 \n"
"w Bandwidth=713 \n"
"p reject 1-65535")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.