using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([a-zA-Z][a-zA-Z\d]|\d[a-zA-Z])(?=\s*,)";
string input = @"3F, 4B, AA, C5, 45, A4B";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}