$re = '/\b([a-zA-Z][a-zA-Z\d]|\d[a-zA-Z])(?=\s*,)/';
$str = '3F, 4B, AA, C5, 45, A4B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);