import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+,)*(\\w+)\\s+(\\w+\\d{6},)*(\\w*\\d{6})";
final String string = "山东大学古籍所,山东大学古籍所,山东大学古籍所,山东大学古籍所 山东济南250100,山东济南250100,山东济南250100,山东济南250100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}