$re = '/(\w+,)*(\w+)\s+(\w+\d{6},)*(\w*\d{6})/mu';
$str = '山东大学古籍所,山东大学古籍所,山东大学古籍所,山东大学古籍所 山东济南250100,山东济南250100,山东济南250100,山东济南250100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);