#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(\S+)\s*)(?:(\S+)\s*)(?:(\S+)\s*)(?:(\S+)\s*)(?:(\S+)\s*)(?:(\S+)\s*)"
Local $sString = "aaa" & @CRLF & _
" bbb" & @CRLF & _
" ccc" & @CRLF & _
" aaa bbb ccc" & @CRLF & _
" ddd eee fff ddd eee fff " & @CRLF & _
" ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff" & @CRLF & _
" ddd eee" & @CRLF & _
" ddd eee fff" & @CRLF & _
" ddd eee fff" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")