import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\S+)\\s*)(?:(\\S+)\\s*)(?:(\\S+)\\s*)(?:(\\S+)\\s*)(?:(\\S+)\\s*)(?:(\\S+)\\s*)";
final String string = "aaa\n"
+ " bbb\n"
+ " ccc\n"
+ " aaa bbb ccc\n"
+ " ddd eee fff ddd eee fff \n"
+ " ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff ddd eee fff\n"
+ " ddd eee\n"
+ " ddd eee fff\n"
+ " ddd eee fff\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}