$re = '/((?<=Description\:[\r\n|\r|\n])(\d+\.|\-)\ (?P<desc>(.+)\.))|((?<=\.[\r\n|\r|\n])((\d+\.|\-)\ (?P<desc2>(.+)\.))(?=[\r\n|\r|\n](\d+\.|\-)|[\r\n|\r|\n]*Reference))/';
$str = '[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 446.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas.
Reference: #232
([\\d]+\\. )(.*?)(?=([\\d]+\\.)|($))
((?<=Description\\:[\\r\\n|\\r|\\n])(\\d+\\.|\\-)\\ (?P<desc>(.+)\\.))|((?<=\\.[\\r\\n|\\r|\\n])((\\d+\\.|\\-)\\ (?P<desc2>(.+)\\.))(?=[\\r\\n|\\r|\\n](\\d+\\.|\\-)|[\\r\\n|\\r|\\n]*Reference))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);