import Foundation
let pattern = #"((?<=Description\:[\r\n|\r|\n])(\d+\.|\-)\ (?P<desc>(.+)\.))|((?<=\.[\r\n|\r|\n])((\d+\.|\-)\ (?P<desc2>(.+)\.))(?=[\r\n|\r|\n](\d+\.|\-)|[\r\n|\r|\n]*Reference))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 446.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas.
Reference: #232
([\d]+\. )(.*?)(?=([\d]+\.)|($))
((?<=Description\:[\r\n|\r|\n])(\d+\.|\-)\ (?P<desc>(.+)\.))|((?<=\.[\r\n|\r|\n])((\d+\.|\-)\ (?P<desc2>(.+)\.))(?=[\r\n|\r|\n](\d+\.|\-)|[\r\n|\r|\n]*Reference))
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)