package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m);databaseName=([^;]*)`)
var str = `jdbc:sqlserver://abc.com:1440;instanceName=MSSQLSERVER2019;databaseName=ab_cd_e;integratedSecurity=false
jdbc:sqlserver://abc.com:1440;instanceName=MSSQLSERVER2019;integratedSecurity=false;databaseName=ab_cd_e
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}