re = /;databaseName=([^;]*)/m
str = 'jdbc:sqlserver://abc.com:1440;instanceName=MSSQLSERVER2019;databaseName=ab_cd_e;integratedSecurity=false
jdbc:sqlserver://abc.com:1440;instanceName=MSSQLSERVER2019;integratedSecurity=false;databaseName=ab_cd_e
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end